Nákup LBTC znovu dostupný
Incident Report for Bitcoinmat
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2024 - 14:02 CET
Identified
Vážení zákazníci, nákup LBTC na zariadeniach Bitcoinmat je znovu spustený a k dispozícií.

Dear customers, purchasing LBTC on Bitcoinmat ATMs is available again.
Posted Sep 16, 2024 - 08:38 CEST
This incident affects: ATMs.