Bitcoinmat Praha - Paralelní Polis/Second Culture dočasne nedostupný.

Incident Report for Bitcoinmat

Update

We are continuing to work on a fix for this issue.
Posted Aug 14, 2025 - 10:50 CEST

Identified

Vážení zákazníci, z dôvodu rekonštrukčných prác je zariadenie Bitcoinmat v Prahe - Paralelní Polis dočasne nedostupné.

Dear customers, due to reconstruction work, ATM in Prague - Paralelni Polis is temporarily unavailable
Posted Aug 05, 2025 - 15:31 CEST
This incident affects: ATMs.